Blackboard Browser Setup

The Truman Blackboard system requires that your browser be up to date and configured correctly. Use this page to check whether you have required plug-ins and features installed or enabled.

Browser Auto Check Results:

Your browser, Unknown, is not compatible by Blackboard.

Your Operating system, Unknown, is not supported by Blackboard.

To view the different types of information on Blackboard course sites, the following plug-ins and features must all be successfully installed or enabled:

JavaScript Unknown
Cookies Unknown
Flash/Flash Video Unknown
PDF/Adobe (Acrobat) Reader Unknown
Java Unknown
Apple QuickTime Player Unknown
Windows Media Player Unknown
Silverlight Unknown
Office (Word, PowerPoint,...) Unknown

Your instructor may require additional software as well.

* If you see "Too old or not detected" message, it does not necessarily mean that you have a problem with your PDF reader. It means that the PDF reader just cannot be determined automatically from your browser. If you have a PDF reader installed, you should be fine.


Browser Issues and Options

Here are some more details about your software.

If the tests above reported that your browser was not compatible with Blackboard, you need to update your browser version. 

You can download the latest browsers and plug-ins from our Technology Requirements page.  In general, the latest production version of your browser is usually the best. However, Blackboard Inc. doesn't always certify new versions immediately.  There are many, many points of compatibility to test.  Always be prepared to try another browser before reporting a problem. 

Operating system Hardware Recommended Browser Notes
Windows 7 (32 and 64-bit) PC

MS Internet Explorer 8 or 9                          Firefox 3.6 or newer  

Google Chrome

IE 7 mostly works, but upgrade soon.  Firefox 3.5 works, but upgrade soon.
Windows XP
(32-bit)
PC

MS Internet Explorer 7 or 8 (IE 9 is not yet supported)
Firefox 3.6 or newer       Google Chrome


Firefox 3.5 mostly works, but upgrade soon.
Windows Vista
(32 or 64-bit)
PC MS Internet Explorer 7, 8, or 9
Firefox 3.6 or newer  Google Chrome
Firefox 3.5 mostly works, but upgrade soon.
Mac OSX 10.7 Lion Mac

Firefox 3.6 or newer

Safari 5.1

Google Chrome

Safari 4 and 4.1 not supported by Blackboard on Lion (10.7).
Mac OSX 10.5 and 10.6
(Leopard and Snow Leopard)
Mac

Firefox 3.6 or newer
Safari 4, 4.1 or 5.1  Google Chrome

Safari 5.1 not supported by Blackboard on Leopard (10.5).
Linux any Firefox 3.6 or newer  Google Chrome Linux not officially supported
but mostly works.

 

It is also very important for both security and functionality that you update your system software regularly:

  • PC users: regularly visit Windows Update or set your system to automatically run Automatic Updates. To turn on Automatic Updates: (1) Click Start, and then Control Panel. Find "System," which may be categorized under Performance and Maintenance. (2) Click System, and then click the Automatic Updates tab. (3) Click the option that you want. Make sure Automatic Updates is not turned off. PC users running Windows 2000 or an earlier version must upgrade to XP or Vista. We have not yet tested Windows 7.
  • Mac users: run Software Update... from the Apple menu. Mac users who are still running 10.3 or earlier versions of Mac OSX should upgrade to Leopard (10.5).